Planning to use i>clicker during Spring 2016 semester? You may need a firmware upgrade

January 14, 2016

As a follow-up to our announcement in December that ETS will be supporting i>clicker version 7, we want to alert you to the possible need for a firmware upgrade. The vendor has recently let us know that some older white base stations (likely those from Spring 2014 and earlier) will need a firmware update. If you obtained your base station prior to 2015, please review our Firmware Upgrade Help article prior to running your first class. 

For additional support, please start by referring to our Instructors Getting Started page, and if you continue to have questions, contact: clickers@berkeley.edu